CVE-2026-33327
High
Description
libvips is a fast image processing library with low memory needs. The `vipsload` operation in versions before and including 8.18.0 could incorrectly determine image dimensions leading to an integer overflow and a subsequent heap-based buffer overflow. This has been patched in version 8.18.1.
SeverityHigh
CVSS7.8
Exploit probability—
ProductLibvips
PublishedJul 20, 2026
First seenJul 20, 2026
Weakness typeCWE-190Integer overflow
How to fix
Update
- libvips libvips8.18.1 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| libvips libvips | v < 8.18.1 | 8.18.1 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
In the Intelligence 360 plan
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.