CVE-2026-33328
Medium
Description
libvips is a fast image processing library with low memory needs. On 32-bit systems in versions before and including 8.18.0, the `gifload` operation could incorrectly determine dimensions leading to an integer overflow. This has been patched in version 8.18.1.
SeverityMedium
CVSS5.5
Exploit probability—
ProductLibvips
PublishedJul 20, 2026
First seenJul 20, 2026
Weakness typeCWE-190Integer overflow
How to fix
Update
- libvips libvips8.18.1 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| libvips libvips | v < 8.18.1 | 8.18.1 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
In the Intelligence 360 plan
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.