CVE-2026-33331

High

Description

oRPC is an tool that helps build APIs that are end-to-end type-safe and adhere to OpenAPI standards. Prior to version 1.13.9, a stored cross-site scripting (XSS) vulnerability exists in the OpenAPI documentation generation of orpc. If an attacker can control any field within the OpenAPI specification (such as info.description), they can break out of the JSON context and execute arbitrary JavaScript when a user views the generated API documentation. This issue has been patched in version 1.13.9.

SeverityHigh
CVSS8.2
Exploit probability—
ProductOrpc
PublishedMar 24, 2026
First seenMar 24, 2026

How to fix

Update
  • orpc orpc1.13.9 or later
  • @orpc/openapi1.13.9 or later

Affected products

ProductAffected versionsFixed in
orpc orpcv < 1.13.91.13.9
@orpc/openapinpmv < 1.13.91.13.9

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.