CVE-2026-3336
High
Description
Improper certificate validation in PKCS7_verify() in AWS-LC allows an unauthenticated user to bypass certificate chain verification when processing PKCS7 objects with multiple signers, except the final signer. Customers of AWS services do not need to take action. Applications using AWS-LC should upgrade to AWS-LC version 1.69.0.
SeverityHigh
CVSS7.5
Exploit probability—
ProductAmazon Aws-lc-sys
PublishedMar 2, 2026
First seenMar 2, 2026
Weakness typeCWE-295CWE-295
How to fix
Update
- amazon aws-lc-sys0.38.0 or later
- amazon aws_libcrypto1.69.0 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| amazon aws-lc-sys | 0.24.0 ≤ v < 0.38.0 | 0.38.0 |
| amazon aws_libcrypto | 1.41.0 ≤ v < 1.69.0 | 1.69.0 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
In the Intelligence 360 plan
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.