CVE-2026-33409
Description
Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Prior to versions 8.6.52 and 9.6.0-alpha.41, an authentication bypass vulnerability allows an attacker to log in as any user who has linked a third-party authentication provider, without knowing the user's credentials. The attacker only needs to know the user's provider ID to gain full access to their account, including a valid session token. This affects Parse Server deployments where the server option allowExpiredAuthDataToken is set to true. The default value is false. This issue has been patched in versions 8.6.52 and 9.6.0-alpha.41.
How to fix
- parseplatform parse-server8.6.52, 9.6.0 or later
- parse-server9.6.0-alpha.41, 8.6.52 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| parseplatform parse-server | v < 8.6.52, 9.0.0 ≤ v < 9.6.0, 9.6.0 | 8.6.52, 9.6.0 |
| parse-servernpm | 9.0.0 ≤ v < 9.6.0-alpha.41, v < 8.6.52 | 9.6.0-alpha.41, 8.6.52 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.