CVE-2026-33412

Medium

Description

Vim is an open source, command line text editor. Prior to version 9.2.0202, a command injection vulnerability exists in Vim's glob() function on Unix-like systems. By including a newline character (\n) in a pattern passed to glob(), an attacker may be able to execute arbitrary shell commands. This vulnerability depends on the user's 'shell' setting. This issue has been patched in version 9.2.0202.

SeverityMedium
CVSS5.6
Exploit probability—
ProductVim
PublishedMar 24, 2026
First seenMar 24, 2026

How to fix

Affected products

ProductAffected versionsFixed in
vim vimv < 9.2.02029.2.0202

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.

CVE-2026-33412 · Vim · Dark Radar