CVE-2026-33414

High

Description

Podman is a tool for managing OCI containers and pods. Versions 4.8.0 through 5.8.1 contain a command injection vulnerability in the HyperV machine backend in pkg/machine/hyperv/stubber.go, where the VM image path is inserted into a PowerShell double-quoted string without sanitization, allowing $() subexpression injection. Because PowerShell evaluates subexpressions inside double-quoted strings before executing the outer command, an attacker who can control the VM image path through a crafted machine name or image directory can execute arbitrary PowerShell commands with the privileges of the Podman process. On typical Windows installations this means SYSTEM-level code execution, and only Windows is affected as the code is exclusive to the HyperV backend. This issue has been patched in version 5.8.2.

SeverityHigh
CVSS7.8
Exploit probability—
ProductPodman
PublishedApr 14, 2026
First seenApr 14, 2026

How to fix

Update
  • podman_project podman5.8.2 or later
  • github.com/containers/podman/v55.8.2 or later

Affected products

ProductAffected versionsFixed in
podman_project podman4.8.0 ≤ v < 5.8.25.8.2
github.com/containers/podman/v4Go4.8.0 ≤ v ≤ 4.9.5, 4.8.0 ≤ v—
github.com/containers/podman/v5Gov < 5.8.25.8.2
github.com/containers/podmanGoNo range specified—
github.com/containers/podman/v2GoNo range specified—
github.com/containers/podman/v3GoNo range specified—

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.