CVE-2026-33435

High

Description

Weblate is a web based localization tool. In versions prior to 5.17, the project backup didn't filter Git and Mercurial configuration files which could lead to remote code execution under certain circumstances. This issue has been fixed in version 5.17. If developers are unable to update immediately, they can limit the scope of the vulnerability by restricting access to the project backup, as it is only accessible to users who can create projects.

SeverityHigh
CVSS8.0
Exploit probability—
ProductWeblate
PublishedApr 15, 2026
First seenApr 15, 2026

How to fix

Update
  • weblate weblate5.17 or later
  • weblate5.17 or later

Affected products

ProductAffected versionsFixed in
weblate weblatev < 5.175.17
weblatePyPIv < 5.175.17

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.