CVE-2026-33439

Critical

Description

Open Access Management (OpenAM) is an access management solution. Prior to 16.0.6, OpenIdentityPlatform OpenAM is vulnerable to pre-authentication Remote Code Execution (RCE) via unsafe Java deserialization of the jato.clientSession HTTP parameter. This bypasses the WhitelistObjectInputStream mitigation that was applied to the jato.pageSession parameter after CVE-2021-35464. An unauthenticated attacker can achieve arbitrary command execution on the server by sending a crafted serialized Java object as the jato.clientSession GET/POST parameter to any JATO ViewBean endpoint whose JSP contains <jato:form> tags (e.g., the Password Reset pages). This vulnerability is fixed in 16.0.6.

SeverityCritical
CVSS9.8
Exploit probability—
ProductOpenidentityplatform Openam
PublishedApr 7, 2026
First seenApr 7, 2026

How to fix

Update
  • openidentityplatform openam16.0.6 or later
  • org.openidentityplatform.openam:openam16.0.6 or later

Affected products

ProductAffected versionsFixed in
openidentityplatform openamv < 16.0.616.0.6
org.openidentityplatform.openam:openamMavenv < 16.0.616.0.6

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.