CVE-2026-33508
Description
Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Prior to versions 8.6.56 and 9.6.0-alpha.45, Parse Server's LiveQuery component does not enforce the requestComplexity.queryDepth configuration setting when processing WebSocket subscription requests. An attacker can send a subscription with deeply nested logical operators, causing excessive recursion and CPU consumption that degrades or disrupts service availability. This issue has been patched in versions 8.6.56 and 9.6.0-alpha.45.
How to fix
- parseplatform parse-server8.6.56, 9.6.0 or later
- parse-server9.6.0-alpha.45, 8.6.56 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| parseplatform parse-server | v < 8.6.56, 9.0.0 ≤ v < 9.6.0, 9.6.0 | 8.6.56, 9.6.0 |
| parse-servernpm | 9.0.0 ≤ v < 9.6.0-alpha.45, v < 8.6.56 | 9.6.0-alpha.45, 8.6.56 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.