CVE-2026-33527
Description
Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Prior to versions 8.6.57 and 9.6.0-alpha.48, an authenticated user can overwrite server-generated session fields such as expiresAt and createdWith when updating their own session via the REST API. This allows bypassing the server's configured session lifetime policy, making a session effectively permanent. This issue has been patched in versions 8.6.57 and 9.6.0-alpha.48.
How to fix
- parseplatform parse-server8.6.57, 9.6.0 or later
- parse-server9.6.0-alpha.48, 8.6.57 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| parseplatform parse-server | v < 8.6.57, 9.0.0 ≤ v < 9.6.0, 9.6.0 | 8.6.57, 9.6.0 |
| parse-servernpm | 9.0.0 ≤ v < 9.6.0-alpha.48, v < 8.6.57 | 9.6.0-alpha.48, 8.6.57 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.