CVE-2026-33538

High

Description

Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Prior to versions 8.6.58 and 9.6.0-alpha.52, an unauthenticated attacker can cause denial of service by sending authentication requests with arbitrary, unconfigured provider names. The server executes a database query for each unconfigured provider before rejecting the request, and since no database index exists for unconfigured providers, each request triggers a full collection scan on the user database. This can be parallelized to saturate database resources. This issue has been patched in versions 8.6.58 and 9.6.0-alpha.52.

SeverityHigh
CVSS7.5
Exploit probability—
ProductParseplatform Parse-server
PublishedMar 24, 2026
First seenMar 24, 2026

How to fix

Update
  • parseplatform parse-server8.6.58, 9.6.0 or later
  • parse-server9.6.0-alpha.52, 8.6.58 or later

Affected products

ProductAffected versionsFixed in
parseplatform parse-serverv < 8.6.58, 9.0.0 ≤ v < 9.6.0, 9.6.08.6.58, 9.6.0
parse-servernpm9.0.0 ≤ v < 9.6.0-alpha.52, v < 8.6.589.6.0-alpha.52, 8.6.58

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.