CVE-2026-33558

Medium

Description

Information exposure vulnerability has been identified in Apache Kafka. The NetworkClient component will output entire requests and responses information in the DEBUG log level in the logs. By default, the log level is set to INFO level. If the DEBUG level is enabled, the sensitive information will be exposed via the requests and responses output log. The entire lists of impacted requests and responses are: * AlterConfigsRequest * AlterUserScramCredentialsRequest * ExpireDelegationTokenRequest * IncrementalAlterConfigsRequest * RenewDelegationTokenRequest * SaslAuthenticateRequest * createDelegationTokenResponse * describeDelegationTokenResponse * SaslAuthenticateResponse This issue affects Apache Kafka: from any version supported the listed API above through v3.9.1, v4.0.0. We advise the Kafka users to upgrade to v3.9.2, v4.0.1, or later to avoid this vulnerability.

SeverityMedium
CVSS5.3
Exploit probability—
ProductApache Kafka
PublishedApr 20, 2026
First seenApr 20, 2026
Weakness typeCWE-533CWE-533

How to fix

Update
  • apache kafka3.9.2 or later
  • org.apache.kafka:kafka-clients3.9.2, 4.0.1 or later
Vendor advisories

Affected products

ProductAffected versionsFixed in
apache kafka0.11.0.0 ≤ v < 3.9.2, 4.0.03.9.2
org.apache.kafka:kafka-clientsMaven0.11.0 ≤ v < 3.9.2, 4.0.0 ≤ v < 4.0.13.9.2, 4.0.1

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.