CVE-2026-33624
Description
Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Prior to versions 8.6.60 and 9.6.0-alpha.54, an attacker who obtains a user's password and a single MFA recovery code can reuse that recovery code an unlimited number of times by sending concurrent login requests. This defeats the single-use design of recovery codes. The attack requires the user's password, a valid recovery code, and the ability to send concurrent requests within milliseconds. This issue has been patched in versions 8.6.60 and 9.6.0-alpha.54.
How to fix
- parseplatform parse-server8.6.60, 9.6.0 or later
- parse-server9.6.0-alpha.54, 8.6.60 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| parseplatform parse-server | v < 8.6.60, 9.0.0 ≤ v < 9.6.0, 9.6.0 | 8.6.60, 9.6.0 |
| parse-servernpm | 9.0.0 ≤ v < 9.6.0-alpha.54, v < 8.6.60 | 9.6.0-alpha.54, 8.6.60 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.