CVE-2026-33642

Critical

Description

Kitty is a cross-platform GPU based terminal. In versions 0.46.2 and below, the handle_compose_command() function in kitty/graphics.c performs bounds validation on composition offsets using unsigned 32-bit arithmetic that is subject to integer wrapping, potentially leading to Heap Buffer Over-Read/Write. An attacker who can write escape sequences to a kitty terminal (e.g., via a malicious file, SSH login banner, or piped content) can supply crafted x_offset/y_offset values that pass the bounds check after wrapping but cause massive out-of-bounds heap memory access in compose_rectangles(). No user interaction is required. No non-default configuration is required. The attacker only needs the ability to produce output in a kitty terminal window. This issue has been fixed in version 0.47.0.

SeverityCritical
CVSS9.9
Exploit probability—
ProductKovidgoyal Kitty
PublishedMay 19, 2026
First seenMay 19, 2026

How to fix

Update
  • kovidgoyal kitty0.47.0 or later

Affected products

ProductAffected versionsFixed in
kovidgoyal kittyv < 0.47.00.47.0

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.

CVE-2026-33642 · Kovidgoyal Kitty · Dark Radar