CVE-2026-33672
Description
Picomatch is a glob matcher written JavaScript. Versions prior to 4.0.4, 3.0.2, and 2.3.2 are vulnerable to a method injection vulnerability affecting the `POSIX_REGEX_SOURCE` object. Because the object inherits from `Object.prototype`, specially crafted POSIX bracket expressions (e.g., `[[:constructor:]]`) can reference inherited method names. These methods are implicitly converted to strings and injected into the generated regular expression. This leads to incorrect glob matching behavior (integrity impact), where patterns may match unintended filenames. The issue does not enable remote code execution, but it can cause security-relevant logic errors in applications that rely on glob matching for filtering, validation, or access control. All users of affected `picomatch` versions that process untrusted or user-controlled glob patterns are potentially impacted. This issue is fixed in picomatch 4.0.4, 3.0.2 and 2.3.2. Users should upgrade to one of these versions or later, depending on their supported release line. If upgrading is not immediately possible, avoid passing untrusted glob patterns to picomatch. Possible mitigations include sanitizing or rejecting untrusted glob patterns, especially those containing POSIX character classes like `[[:...:]]`; avoiding the use of POSIX bracket expressions if user input is involved; and manually patching the library by modifying `POSIX_REGEX_SOURCE` to use a null prototype.
How to fix
- jonschlinkert picomatch2.3.2, 3.0.2, 4.0.4 or later
- picomatch4.0.4, 3.0.2, 2.3.2 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| jonschlinkert picomatch | v < 2.3.2, 3.0.0 ≤ v < 3.0.2, 4.0.0 ≤ v < 4.0.4 | 2.3.2, 3.0.2, 4.0.4 |
| picomatchnpm | 4.0.0 ≤ v < 4.0.4, 3.0.0 ≤ v < 3.0.2, v < 2.3.2 | 4.0.4, 3.0.2, 2.3.2 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.