CVE-2026-33804

High

Description

@fastify/middie versions 9.3.1 and earlier are vulnerable to middleware bypass when the deprecated Fastify ignoreDuplicateSlashes option is enabled. The middleware path matching logic does not account for duplicate slash normalization performed by Fastify's router, allowing requests with duplicate slashes to bypass middleware authentication and authorization checks. This only affects applications using the deprecated ignoreDuplicateSlashes option. Upgrade to @fastify/middie 9.3.2 to fix this issue. There are no workarounds other than disabling the ignoreDuplicateSlashes option.

SeverityHigh
CVSS7.4
Exploit probability—
Product@fastify/middie
PublishedApr 16, 2026
First seenApr 16, 2026
Weakness typeCWE-436CWE-436

How to fix

Update
  • @fastify/middie9.3.2 or later
  • fastify fastify\/middie9.3.2 or later

Affected products

ProductAffected versionsFixed in
@fastify/middienpmv < 9.3.29.3.2
fastify fastify\/middiev < 9.3.29.3.2

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.