CVE-2026-34032
Medium
Description
Improper Null Termination, Out-of-bounds Read vulnerability in Apache HTTP Server. This issue affects Apache HTTP Server: through 2.4.66. Users are recommended to upgrade to version 2.4.67, which fixes the issue.
SeverityMedium
CVSS5.3
Exploit probability—
Product
Apache Http Server
PublishedMay 4, 2026
First seenMay 4, 2026
Weakness typeCWE-170CWE-170CWE-125Out-of-bounds read
How to fix
Update
- apache http_server2.4.67 or later
Vendor advisories
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| apache http_server | v < 2.4.67 | 2.4.67 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
In the Intelligence 360 plan
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.