CVE-2026-34033
Description
Improper Neutralization of Script-Related HTML Tags in a Web Page (Basic XSS) vulnerability in Apache Answer. This issue affects Apache Answer: through 2.0.0. User-supplied content was included in notification emails without proper escaping, allowing authenticated users to inject arbitrary HTML into emails sent to other users. Users are recommended to upgrade to version 2.0.1, which fixes the issue.
How to fix
- apache answer2.0.1 or later
- github.com/apache/incubator-answer1.7.2-0.20260509080709-d1a4092c61cc or later
- github.com/apache/answer1.7.2-0.20260509080709-d1a4092c61cc or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| apache answer | v < 2.0.1 | 2.0.1 |
| github.com/apache/incubator-answerGo | v < 1.7.2-0.20260509080709-d1a4092c61cc | 1.7.2-0.20260509080709-d1a4092c61cc |
| github.com/apache/answerGo | v < 1.7.2-0.20260509080709-d1a4092c61cc | 1.7.2-0.20260509080709-d1a4092c61cc |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.