CVE-2026-34052

Medium

Description

LTI JupyterHub Authenticator is a JupyterHub authenticator for LTI. Prior to version 1.6.3, the LTI 1.1 validator stores OAuth nonces in a class-level dictionary that grows without bounds. Nonces are added before signature validation, so an attacker with knowledge of a valid consumer key can send repeated requests with unique nonces to gradually exhaust server memory, causing a denial of service. This issue has been patched in version 1.6.3.

SeverityMedium
CVSS5.9
Exploit probability—
ProductLti Jupyterhub Authenticator
PublishedApr 3, 2026
First seenApr 3, 2026

How to fix

Update
  • jupyter lti_jupyterhub_authenticator1.6.3 or later
  • jupyterhub-ltiauthenticator1.6.3 or later

Affected products

ProductAffected versionsFixed in
jupyter lti_jupyterhub_authenticatorv < 1.6.31.6.3
jupyterhub-ltiauthenticatorPyPIv < 1.6.31.6.3

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.