CVE-2026-34059

High

Description

Buffer Over-read vulnerability in Apache HTTP Server. This issue affects Apache HTTP Server: through 2.4.66. Users are recommended to upgrade to version 2.4.67, which fixes the issue.

SeverityHigh
CVSS7.5
Exploit probability—
ProductApache Http Server
PublishedMay 4, 2026
First seenMay 4, 2026
Weakness typeCWE-126CWE-126

How to fix

Update
  • apache http_server2.4.67 or later

Affected products

ProductAffected versionsFixed in
apache http_serverv < 2.4.672.4.67

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.