CVE-2026-34077
Description
React Router is a router for React. In versions 7.7.0 through 7.13.1, when using React Router's unstable React Server Components (RSC) APIs, there is a potential client-side Cross-Site Scripting (XSS) vulnerability in the RSC redirect handling if redirects come from untrusted sources. This does not impact applications that are not using the unstable RSC APIs in React Router. This is patched in version 7.13.2.
How to fix
- shopify react-router7.14.0 or later
- turbo-stream turbo_stream3.0.0 or later
- react-router7.14.0 or later
- turbo-stream3.0.0 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| shopify react-router | 7.0.0 ≤ v < 7.14.0 | 7.14.0 |
| turbo-stream turbo_stream | v < 3.0.0 | 3.0.0 |
| react-routernpm | 7.0.0 ≤ v < 7.14.0 | 7.14.0 |
| turbo-streamnpm | v < 3.0.0 | 3.0.0 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.