CVE-2026-34154

Medium

Description

Discourse is an open-source discussion platform. In versions prior to 2026.1.4, 2026.3.1, 2026.4.1 and 2026.5.0-latest.1, a vulnerability in the discourse-subscriptions plugin allows users to gain access to subscription-gated groups without completing payment. This issue has been fixed in versions 2026.1.4, 2026.3.1, 2026.4.1 and 2026.5.0-latest.1.

SeverityMedium
CVSS5.3
Exploit probability—
ProductDiscourse
PublishedMay 19, 2026
First seenMay 19, 2026

How to fix

Update
  • discourse discourse2026.1.4, 2026.3.1, 2026.4.1 or later

Affected products

ProductAffected versionsFixed in
discourse discourse2026.1.0 ≤ v < 2026.1.4, 2026.3.0 ≤ v < 2026.3.1, 2026.4.0 ≤ v < 2026.4.1, 2026.5.02026.1.4, 2026.3.1, 2026.4.1

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.