CVE-2026-34231

Medium

Description

Slippers is a UI component framework for Django. Prior to version 0.6.3, a Cross-Site Scripting (XSS) vulnerability exists in the {% attrs %} template tag of the slippers Django package. When a context variable containing untrusted data is passed to {% attrs %}, the value is interpolated into an HTML attribute string without escaping, allowing an attacker to break out of the attribute context and inject arbitrary HTML or JavaScript into the rendered page. This issue has been patched in version 0.6.3.

SeverityMedium
CVSS6.1
Exploit probability—
ProductDjango Slippers
PublishedMar 31, 2026
First seenMar 31, 2026

How to fix

Update
  • slippers0.6.3 or later

Affected products

ProductAffected versionsFixed in
django slippersv ≤ 0.6.2—
slippersPyPIv < 0.6.30.6.3

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.

CVE-2026-34231 · Django Slippers · Dark Radar