CVE-2026-34236

High

Description

Auth0-PHP is a PHP SDK for Auth0 Authentication and Management APIs. From version 8.0.0 to before version 8.19.0, in applications built with the Auth0 PHP SDK, cookies are encrypted with insufficient entropy, which may result in threat actors brute-forcing the encryption key and forging session cookies. This issue has been patched in version 8.19.0.

SeverityHigh
CVSS8.2
Exploit probability—
ProductAuth0-php
PublishedApr 1, 2026
First seenApr 1, 2026
Weakness typeCWE-331CWE-331

How to fix

Update
  • auth0 auth0-php8.19.0 or later
  • auth0/auth0-php8.19.0 or later

Affected products

ProductAffected versionsFixed in
auth0 auth0-php8.0.0 ≤ v < 8.19.08.19.0
auth0/auth0-phpPackagist8.0.0 ≤ v < 8.19.08.19.0

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.