CVE-2026-34356

High

Description

Heap-based Buffer Overflow vulnerability in Apache HTTP Server with malicious backend servers and ProxyPassReverseCookie* This issue affects Apache HTTP Server: from 2.4.0 through 2.4.67. Users are recommended to upgrade to version 2.4.68, which fixes the issue.

SeverityHigh
CVSS7.5
Exploit probability—
ProductApache Http Server
PublishedJun 8, 2026
First seenJun 8, 2026
Weakness typeCWE-122CWE-122

How to fix

Update
  • apache http_server2.4.68 or later

Affected products

ProductAffected versionsFixed in
apache http_server2.4.0 ≤ v < 2.4.682.4.68

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.