CVE-2026-34400

Critical

Description

Alerta is a monitoring tool. Prior to version 9.1.0, the Query string search API (q=) was vulnerable to SQL injection via the Postgres query parser, which built WHERE clauses by interpolating user-supplied search terms directly into SQL strings via f-strings. This issue has been patched in version 9.1.0.

SeverityCritical
CVSS9.8
Exploit probability—
ProductAlerta
PublishedMar 31, 2026
First seenMar 31, 2026
Weakness typeCWE-89SQL injection

How to fix

Update
  • alerta_project alerta9.1.0 or later
  • alerta-server9.1.0 or later

Affected products

ProductAffected versionsFixed in
alerta_project alertav < 9.1.09.1.0
alerta-serverPyPIv < 9.1.09.1.0

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.