CVE-2026-34476

High

Description

Server-Side Request Forgery via SW-URL Header vulnerability in Apache SkyWalking MCP. This issue affects Apache SkyWalking MCP: 0.1.0. Users are recommended to upgrade to version 0.2.0, which fixes this issue.

SeverityHigh
CVSS7.1
Exploit probability—
ProductApache Skywalking Mcp
PublishedApr 13, 2026
First seenApr 13, 2026

How to fix

Update
  • apache skywalking_mcp0.2.0 or later
  • github.com/apache/skywalking-mcp0.2.0 or later

Affected products

ProductAffected versionsFixed in
apache skywalking_mcp0.1.0 ≤ v < 0.2.00.2.0
github.com/apache/skywalking-mcpGov < 0.2.00.2.0

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.