CVE-2026-34486

HighActively exploited (CISA KEV)

Description

Missing Encryption of Sensitive Data vulnerability in Apache Tomcat due to the fix for CVE-2026-29146 allowing the bypass of the EncryptInterceptor. This issue affects Apache Tomcat: 11.0.20, 10.1.53, 9.0.116. Users are recommended to upgrade to version 11.0.21, 10.1.54 or 9.0.117, which fix the issue.

SeverityHigh
CVSS7.5
Exploit probability—
ProductApache Tomcat
PublishedApr 9, 2026
First seenApr 9, 2026
Added to KEVAug 4, 2026
Weakness typeCWE-311CWE-311

How to fix

CISA required action

Apply mitigations in accordance with vendor instructions, ensuring compliance with CISA’s BOD 26-04 Prioritizing Security Updates Based on Risk (see URL in Notes) guidance and CISA’s “Forensics Triage Requirements” (see URL in Notes). Follow applicable BOD 26-04 guidance for cloud services or discontinue use of the product if mitigations are unavailable. Stakeholders are responsible for evaluating each asset's internet exposure and ensuring adherence to BOD 26-04 patching guidelines.

CISA due date: Aug 7, 2026
Update
  • org.apache.tomcat:tomcat-tribes11.0.21, 10.1.54, 9.0.117 or later
  • org.apache.tomcat:tomcat11.0.21, 10.1.54, 9.0.117 or later

Affected products

ProductAffected versionsFixed in
apache tomcat9.0.116, 10.1.53, 11.0.20—
redhat jboss_web_server7.0.0—
redhat enterprise_linux8.0, 9.0, 10.0—
redhat enterprise_linux_els7.0—
redhat enterprise_linux_eus10.0—
redhat enterprise_linux_tus8.8—
redhat enterprise_linux_update_services_for_sap_solutions8.8, 9.2, 9.4, 9.6—
org.apache.tomcat:tomcat-tribesMaven11.0.20 ≤ v < 11.0.21, 10.1.53 ≤ v < 10.1.54, 9.0.116 ≤ v < 9.0.11711.0.21, 10.1.54, 9.0.117
org.apache.tomcat:tomcatMaven11.0.20 ≤ v < 11.0.21, 10.1.53 ≤ v < 10.1.54, 9.0.116 ≤ v < 9.0.11711.0.21, 10.1.54, 9.0.117

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.