CVE-2026-34487

High

Description

Insertion of Sensitive Information into Log File vulnerability in the cloud membership for clustering component of Apache Tomcat exposed the Kubernetes bearer token. This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.20, from 10.1.0-M1 through 10.1.53, from 9.0.13 through 9.0.116. Users are recommended to upgrade to version 11.0.21, 10.1.54 or 9.0.117, which fix the issue.

SeverityHigh
CVSS7.5
Exploit probability—
ProductApache Tomcat
PublishedApr 9, 2026
First seenApr 9, 2026
Weakness typeCWE-532CWE-532

How to fix

Update
  • apache tomcat9.0.117, 10.1.54, 11.0.21 or later
  • org.apache.tomcat:tomcat-tribes9.0.117, 10.1.54, 11.0.21 or later
  • org.apache.tomcat:tomcat9.0.117, 10.1.54, 11.0.21 or later
  • org.apache.tomcat.embed:tomcat-embed-core9.0.117, 10.1.54, 11.0.21 or later

Affected products

ProductAffected versionsFixed in
apache tomcat9.0.13 ≤ v < 9.0.117, 10.1.0 ≤ v < 10.1.54, 11.0.0 ≤ v < 11.0.219.0.117, 10.1.54, 11.0.21
org.apache.tomcat:tomcat-tribesMaven9.0.13 ≤ v < 9.0.117, 10.1.0-M1 ≤ v < 10.1.54, 11.0.0-M1 ≤ v < 11.0.219.0.117, 10.1.54, 11.0.21
org.apache.tomcat:tomcatMaven9.0.13 ≤ v < 9.0.117, 10.1.0-M1 ≤ v < 10.1.54, 11.0.0-M1 ≤ v < 11.0.219.0.117, 10.1.54, 11.0.21
org.apache.tomcat.embed:tomcat-embed-coreMaven9.0.13 ≤ v < 9.0.117, 10.1.0-M1 ≤ v < 10.1.54, 11.0.0-M1 ≤ v < 11.0.219.0.117, 10.1.54, 11.0.21

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.

CVE-2026-34487 · Apache Tomcat · Dark Radar