CVE-2026-34500
Medium
Description
CLIENT_CERT authentication does not fail as expected for some scenarios when soft fail is disabled and FFM is used in Apache Tomcat. This issue affects Apache Tomcat: from 11.0.0-M14 through 11.0.20, from 10.1.22 through 10.1.53, from 9.0.92 through 9.0.116. Users are recommended to upgrade to version 11.0.21, 10.1.54 or 9.0.117, which fixes the issue.
SeverityMedium
CVSS6.5
Exploit probability—
Product
Apache Tomcat
PublishedApr 9, 2026
First seenApr 9, 2026
Weakness typeCWE-287Improper authentication
How to fix
Update
- apache tomcat9.0.117, 10.1.54, 11.0.21 or later
- org.apache.tomcat:tomcat-coyote-ffm9.0.117, 10.1.54, 11.0.21 or later
Vendor advisories
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| apache tomcat | 9.0.92 ≤ v < 9.0.117, 10.1.22 ≤ v < 10.1.54, 11.0.1 ≤ v < 11.0.21, 11.0.0 | 9.0.117, 10.1.54, 11.0.21 |
| org.apache.tomcat:tomcat-coyote-ffmMaven | 9.0.92 ≤ v < 9.0.117, 10.1.22 ≤ v < 10.1.54, 11.0.0-M14 ≤ v < 11.0.21 | 9.0.117, 10.1.54, 11.0.21 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
In the Intelligence 360 plan
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.