CVE-2026-34571

Critical

Description

CI4MS is a CodeIgniter 4-based CMS skeleton that delivers a production-ready, modular architecture with RBAC authorization and theme support. Prior to version 0.31.0.0, a Stored Cross-Site Scripting (Stored XSS) vulnerability exists in the backend user management functionality. The application fails to properly sanitize user-controlled input before rendering it in the administrative interface, allowing attackers to inject persistent JavaScript code. This results in automatic execution whenever backend users access the affected page, enabling session hijacking, privilege escalation, and full administrative account compromise. This issue has been patched in version 0.31.0.0.

SeverityCritical
CVSS9.9
Exploit probability—
ProductCi4-cms-erp Ci4ms
PublishedApr 1, 2026
First seenApr 1, 2026

How to fix

Update
  • ci4-cms-erp ci4ms0.31.0.0 or later
  • ci4-cms-erp/ci4ms0.31.0.0 or later

Affected products

ProductAffected versionsFixed in
ci4-cms-erp ci4msv < 0.31.0.00.31.0.0
ci4-cms-erp/ci4msPackagistv < 0.31.0.00.31.0.0

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.