CVE-2026-34574

Medium

Description

Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Prior to versions 8.6.69 and 9.7.0-alpha.14, an authenticated user can bypass the immutability guard on session fields (expiresAt, createdWith) by sending a null value in a PUT request to the session update endpoint. This allows nullifying the session expiry, making the session valid indefinitely and bypassing configured session length policies. This issue has been patched in versions 8.6.69 and 9.7.0-alpha.14.

SeverityMedium
CVSS5.4
Exploit probability—
ProductParseplatform Parse-server
PublishedMar 31, 2026
First seenMar 31, 2026
Weakness typeCWE-697CWE-697

How to fix

Update
  • parseplatform parse-server8.6.69, 9.7.0 or later
  • parse-server9.7.0-alpha.14, 8.6.69 or later

Affected products

ProductAffected versionsFixed in
parseplatform parse-serverv < 8.6.69, 9.0.0 ≤ v < 9.7.0, 9.7.08.6.69, 9.7.0
parse-servernpm9.0.0 ≤ v < 9.7.0-alpha.14, v < 8.6.699.7.0-alpha.14, 8.6.69

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.