CVE-2026-34595
Description
Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Prior to versions 8.6.70 and 9.7.0-alpha.18, an authenticated user with find class-level permission can bypass the protectedFields class-level permission setting on LiveQuery subscriptions. By sending a subscription with a $or, $and, or $nor operator value as a plain object with numeric keys and a length property (an "array-like" object) instead of an array, the protected-field guard is bypassed. The subscription event firing acts as a binary oracle, allowing the attacker to infer whether a protected field matches a given test value. This issue has been patched in versions 8.6.70 and 9.7.0-alpha.18.
How to fix
- parseplatform parse-server8.6.70, 9.7.0 or later
- parse-server9.7.0-alpha.16, 8.6.70 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| parseplatform parse-server | v < 8.6.70, 9.0.0 ≤ v < 9.7.0, 9.7.0 | 8.6.70, 9.7.0 |
| parse-servernpm | 9.0.0 ≤ v < 9.7.0-alpha.16, v < 8.6.70 | 9.7.0-alpha.16, 8.6.70 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.