CVE-2026-34748

High

Description

Payload is a free and open source headless content management system. Prior to version 3.78.0 in @payloadcms/next, a stored Cross-Site Scripting (XSS) vulnerability existed in the admin panel. An authenticated user with write access to a collection could save content that, when viewed by another user, would execute in their browser. This issue has been patched in version 3.78.0.

SeverityHigh
CVSS8.7
Exploit probability—
ProductPayload
PublishedApr 1, 2026
First seenApr 1, 2026

How to fix

Update
  • payloadcms payload3.78.0 or later
  • @payloadcms/next3.78.0 or later

Affected products

ProductAffected versionsFixed in
payloadcms payloadv < 3.78.03.78.0
@payloadcms/nextnpmv < 3.78.03.78.0

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.