CVE-2026-34753

Medium

Description

vLLM is an inference and serving engine for large language models (LLMs). From 0.16.0 to before 0.19.0, a server-side request forgery (SSRF) vulnerability in download_bytes_from_url allows any actor who can control batch input JSON to make the vLLM batch runner issue arbitrary HTTP/HTTPS requests from the server, without any URL validation or domain restrictions. This can be used to target internal services (e.g. cloud metadata endpoints or internal HTTP APIs) reachable from the vLLM host. This vulnerability is fixed in 0.19.0.

SeverityMedium
CVSS5.4
Exploit probability—
ProductVllm
PublishedApr 6, 2026
First seenApr 6, 2026

How to fix

Update
  • vllm vllm0.19.0 or later
  • vllm0.19.0 or later

Affected products

ProductAffected versionsFixed in
vllm vllm0.16.0 ≤ v < 0.19.00.19.0
vllmPyPI0.16.0 ≤ v < 0.19.00.19.0

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.