CVE-2026-34756

Medium

Description

vLLM is an inference and serving engine for large language models (LLMs). From 0.1.0 to before 0.19.0, a Denial of Service vulnerability exists in the vLLM OpenAI-compatible API server. Due to the lack of an upper bound validation on the n parameter in the ChatCompletionRequest and CompletionRequest Pydantic models, an unauthenticated attacker can send a single HTTP request with an astronomically large n value. This completely blocks the Python asyncio event loop and causes immediate Out-Of-Memory crashes by allocating millions of request object copies in the heap before the request even reaches the scheduling queue. This vulnerability is fixed in 0.19.0.

SeverityMedium
CVSS6.5
Exploit probability—
ProductVllm
PublishedApr 6, 2026
First seenApr 6, 2026

How to fix

Affected products

ProductAffected versionsFixed in
vllm vllm0.1.0 ≤ v < 0.19.00.19.0
vllmPyPI0.1.0 ≤ v < 0.19.00.19.0

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.