CVE-2026-34884

Critical

Description

SSRF via set_skywalking_url Tool and GraphQL expression injection vulnerability in Apache SkyWalking MCP. This issue affects Apache SkyWalking MCP: 0.1.0. Users are recommended to upgrade to version 0.2.0, which fixes this issue.

SeverityCritical
CVSS9.8
Exploit probability—
ProductApache Skywalking Mcp
PublishedAug 18, 2026
First seenAug 18, 2026

How to fix

Update
  • apache skywalking_mcp0.2.0 or later

Affected products

ProductAffected versionsFixed in
apache skywalking_mcp0.1.0 ≤ v < 0.2.00.2.0

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.

CVE-2026-34884 · Apache Skywalking Mcp · Dark Radar