CVE-2026-34905
Description
Exposure of Sensitive Information to an Unauthorized Actor vulnerability in Apache Answer. This issue affects Apache Answer: through 2.0.0. The unlisted question feature did not enforce access restrictions on direct API endpoints, allowing authenticated users to discover and access unlisted questions, their answers, comments, and revision history. Users are recommended to upgrade to version 2.0.1, which fixes the issue.
How to fix
- apache answer2.0.1 or later
- github.com/apache/incubator-answer1.7.2-0.20260509071350-11c80384f13a or later
- github.com/apache/answer1.7.2-0.20260509071350-11c80384f13a or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| apache answer | v < 2.0.1 | 2.0.1 |
| github.com/apache/incubator-answerGo | v < 1.7.2-0.20260509071350-11c80384f13a | 1.7.2-0.20260509071350-11c80384f13a |
| github.com/apache/answerGo | v < 1.7.2-0.20260509071350-11c80384f13a | 1.7.2-0.20260509071350-11c80384f13a |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.