CVE-2026-34972
Medium
Description
OpenFGA is a high-performance and flexible authorization/permission engine built for developers and inspired by Google Zanzibar. From 1.8.0 to 1.13.1, under specific conditions, BatchCheck calls with multiple checks sent for the same object, relation, and user combination can result in improper policy enforcement. This vulnerability is fixed in 1.14.0.
SeverityMedium
CVSS5.0
Exploit probability—
ProductOpenfga
PublishedApr 6, 2026
First seenApr 6, 2026
Weakness typeCWE-863Incorrect authorization
How to fix
Update
- openfga openfga1.14.0 or later
- openfga helm_charts0.2.62 or later
- github.com/openfga/openfga1.14.0 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| openfga openfga | 1.8.0 ≤ v < 1.14.0 | 1.14.0 |
| openfga helm_charts | 0.2.16 ≤ v < 0.2.62 | 0.2.62 |
| github.com/openfga/openfgaGo | 1.8.0 ≤ v < 1.14.0 | 1.14.0 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
In the Intelligence 360 plan
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.