CVE-2026-35175
Medium
Description
Ajenti is a Linux and BSD modular server admin panel. Prior to 2.2.15, an authenticated user (using the auth_users plugin authentication method) could install a custom package even if this user is not superuser. This vulnerability is fixed in 2.2.15.
SeverityMedium
CVSS6.5
Exploit probability20. percentile0.3%
ProductAjenti
PublishedApr 6, 2026
First seenApr 6, 2026
Weakness typeCWE-862Missing authorization
How to fix
Update
- ajenti ajenti2.2.15 or later
- ajenti-panel2.2.15 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| ajenti ajenti | v < 2.2.15 | 2.2.15 |
| ajenti-panelPyPI | v < 2.2.15 | 2.2.15 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
In the Intelligence 360 plan
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.