CVE-2026-35194

High

Description

Code injection in SQL code generation in Apache Flink 1.15.0 through 1.20.x and 2.0.0 through 2.x allows authenticated users with query submission privileges to execute arbitrary code on TaskManagers via maliciously crafted SQL queries. The vulnerability affects JSON functions (1.15.0+) and LIKE expressions with ESCAPE clauses (1.17.0+). User-controlled strings are interpolated into generated Java code without proper escaping, allowing attackers to break out of string literals and inject arbitrary expressions. Users are recommended to upgrade to either version 1.20.4, 2.0.2, 2.1.2 or 2.2.1, which fixes this issue.

SeverityHigh
CVSS8.1
Exploit probability—
ProductApache Flink
PublishedMay 15, 2026
First seenMay 15, 2026

How to fix

Update
  • apache flink1.20.4, 2.0.2, 2.1.2 or later
  • org.apache.flink:flink-table-planner_2.121.20.4, 2.0.2, 2.1.2, 2.2.1 or later
  • org.apache.flink:flink-table-api-java1.20.4, 2.0.2, 2.1.2, 2.2.1 or later
  • org.apache.flink:flink-table-runtime1.20.4, 2.0.2, 2.1.2, 2.2.1 or later

Affected products

ProductAffected versionsFixed in
apache flink1.15.0 ≤ v < 1.20.4, 2.0.0 ≤ v < 2.0.2, 2.1.0 ≤ v < 2.1.2, 2.2.01.20.4, 2.0.2, 2.1.2
org.apache.flink:flink-table-planner_2.12Maven1.15.0 ≤ v < 1.20.4, 2.0.0 ≤ v < 2.0.2, 2.1.0 ≤ v < 2.1.2, 2.2.0 ≤ v < 2.2.11.20.4, 2.0.2, 2.1.2, 2.2.1
org.apache.flink:flink-table-api-javaMaven1.15.0 ≤ v < 1.20.4, 2.0.0 ≤ v < 2.0.2, 2.1.0 ≤ v < 2.1.2, 2.2.0 ≤ v < 2.2.11.20.4, 2.0.2, 2.1.2, 2.2.1
org.apache.flink:flink-table-runtimeMaven1.15.0 ≤ v < 1.20.4, 2.0.0 ≤ v < 2.0.2, 2.1.0 ≤ v < 2.1.2, 2.2.0 ≤ v < 2.2.11.20.4, 2.0.2, 2.1.2, 2.2.1

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.