CVE-2026-3520

High

Description

Multer is a node.js middleware for handling `multipart/form-data`. A vulnerability in Multer prior to version 2.1.1 allows an attacker to trigger a Denial of Service (DoS) by sending malformed requests, potentially causing stack overflow. Users should upgrade to version 2.1.1 to receive a patch. No known workarounds are available.

SeverityHigh
CVSS7.5
Exploit probability—
ProductExpressjs Multer
PublishedMar 4, 2026
First seenMar 4, 2026
Weakness typeCWE-674CWE-674

How to fix

Update
  • expressjs multer2.1.1 or later
  • multer2.1.1 or later

Affected products

ProductAffected versionsFixed in
expressjs multerv < 2.1.12.1.1
multernpmv < 2.1.12.1.1

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.