CVE-2026-35204
Description
Helm is a package manager for Charts for Kubernetes. From 4.0.0 to 4.1.3, a specially crafted Helm plugin, when installed or updated, will cause Helm to write the contents of the plugin to an arbitrary filesystem location. To prevent this, validate that the plugin.yaml of the Helm plugin does not include a version: field containing POSIX dot-dot path separators ie. "/../". This vulnerability is fixed in 4.1.4.
How to fix
- helm helm4.1.4 or later
- helm.sh/helm/v44.1.4 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| helm helm | 4.0.0 ≤ v < 4.1.4 | 4.1.4 |
| helm.sh/helm/v4Go | 4.0.0 ≤ v < 4.1.4 | 4.1.4 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.