CVE-2026-35401

High

Description

Saleor is an e-commerce platform. From 2.0.0 to before 3.23.0a3, 3.22.47, 3.21.54, and 3.20.118, a malicious actor can include many GraphQL mutations or queries in a single API call using aliases or chaining multiple mutations, resulting in resource exhaustion. This vulnerability is fixed in 3.23.0a3, 3.22.47, 3.21.54, and 3.20.118.

SeverityHigh
CVSS7.5
Exploit probability—
ProductSaleor
PublishedApr 8, 2026
First seenApr 8, 2026

How to fix

Update
  • saleor saleor3.20.118, 3.21.54, 3.22.47 or later

Affected products

ProductAffected versionsFixed in
saleor saleor2.0.0 ≤ v < 3.20.118, 3.21.0 ≤ v < 3.21.54, 3.22.0 ≤ v < 3.22.47, 3.23.03.20.118, 3.21.54, 3.22.47

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.