CVE-2026-35479

Medium

Description

InvenTree is an Open Source Inventory Management System. Prior to 1.2.7 and 1.3.0, any users who have staff access permissions can install plugins via the API, without requiring "superuser" account access. This level of permission requirement is out of alignment with other plugin actions (such as uninstalling) which do require superuser access. The vulnerability allows staff users (who may be considered to have a lower level of trust than a superuser account) to install arbitrary (and potentially harmful) plugins. This vulnerability is fixed in 1.2.7 and 1.3.0.

SeverityMedium
CVSS6.6
Exploit probability—
ProductInventree
PublishedApr 8, 2026
First seenApr 8, 2026
Weakness typeCWE-285CWE-285

How to fix

Update
  • inventree_project inventree1.2.7 or later

Affected products

ProductAffected versionsFixed in
inventree_project inventreev < 1.2.71.2.7

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.

CVE-2026-35479 · Inventree · Dark Radar