CVE-2026-35560

High

Description

Improper certificate validation in the identity provider connection components in Amazon Athena ODBC driver before 2.1.0.0 might allow a man-in-the-middle threat actor to intercept authentication credentials due to insufficient default transport security when connecting to identity providers. This only applies to connections with external identity providers and does not apply to connections with Athena. To remediate this issue, users should upgrade to version 2.1.0.0.

SeverityHigh
CVSS7.4
Exploit probability—
ProductAmazon Athena Odbc
PublishedApr 3, 2026
First seenApr 3, 2026
Weakness typeCWE-295CWE-295

How to fix

Affected products

ProductAffected versionsFixed in
amazon athena_odbcv < 2.1.0.02.1.0.0

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.