CVE-2026-39380

Medium

Description

Open Source Point of Sale is a web based point-of-sale application written in PHP using CodeIgniter framework. Prior to 3.4.3, a Stored Cross-Site Scripting (XSS) vulnerability exists in the Stock Locations configuration feature. The application fails to properly sanitize user input supplied through the stock_location parameter, allowing attackers to inject malicious JavaScript code that is stored in the database and executed when rendered in the Employees interface. This vulnerability is fixed in 3.4.3.

SeverityMedium
CVSS5.4
Exploit probability—
ProductOpensourcepos Open Source Point Of Sale
PublishedApr 7, 2026
First seenApr 7, 2026

How to fix

Update
  • opensourcepos open_source_point_of_sale3.4.3 or later

Affected products

ProductAffected versionsFixed in
opensourcepos open_source_point_of_salev < 3.4.33.4.3

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.

CVE-2026-39380 · Opensourcepos Open Source Point Of Sale · Dark Radar