CVE-2026-3965

Medium

Description

A security vulnerability has been detected in whyour qinglong up to 2.20.1. Affected is an unknown function of the file back/loaders/express.ts of the component API Interface. The manipulation of the argument command leads to protection mechanism failure. The attack may be initiated remotely. The exploit has been disclosed publicly and may be used. Upgrading to version 2.20.2 is able to address this issue. The identifier of the patch is 6bec52dca158481258315ba0fc2f11206df7b719. It is advisable to upgrade the affected component. The code maintainer was informed beforehand about the issues. He reacted very fast and highly professional.

SeverityMedium
CVSS6.3
Exploit probability—
Product@whyour/qinglong
PublishedMar 12, 2026
First seenMar 12, 2026
Weakness typeCWE-693CWE-693

How to fix

Affected products

ProductAffected versionsFixed in
@whyour/qinglongnpmv < 2.20.22.20.2

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.