CVE-2026-39979
Description
jq is a command-line JSON processor. In commits before 2f09060afab23fe9390cce7cb860b10416e1bf5f, the jv_parse_sized() API in libjq accepts a counted buffer with an explicit length parameter, but its error-handling path formats the input buffer using %s in jv_string_fmt(), which reads until a NUL terminator is found rather than respecting the caller-supplied length. This means that when malformed JSON is passed in a non-NUL-terminated buffer, the error construction logic performs an out-of-bounds read past the end of the buffer. The vulnerability is reachable by any libjq consumer calling jv_parse_sized() with untrusted input, and depending on memory layout, can result in memory disclosure or process termination. The issue has been patched in commit 2f09060afab23fe9390cce7cb860b10416e1bf5f.
How to fix
- jqlang jq1.8.2 or later
- redhat ai_inference_server3.2.2, 3.3.5 or later
- redhat openshift_ai3.4.3 or later
- redhat openshift_container_platform4.12.92, 4.13.68, 4.14.68, 4.15.65, 4.16.64, 4.17.55, 4.18.44, 4.19.33 or later
- access.redhat.com/errata/RHSA-2026:26528
- access.redhat.com/errata/RHSA-2026:26542
- access.redhat.com/errata/RHSA-2026:28887
- access.redhat.com/errata/RHSA-2026:23233
- access.redhat.com/errata/RHSA-2026:25044
- access.redhat.com/errata/RHSA-2026:34098
- access.redhat.com/errata/RHSA-2026:25181
- access.redhat.com/errata/RHSA-2026:23245
- access.redhat.com/errata/RHSA-2026:16252
- access.redhat.com/errata/RHSA-2026:18048
- access.redhat.com/errata/RHSA-2026:18047
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| jqlang jq | v < 1.8.2 | 1.8.2 |
| redhat ai_inference_server | 3.2.0 ≤ v < 3.2.2, 3.3.0 ≤ v < 3.3.5 | 3.2.2, 3.3.5 |
| redhat ansible_automation_platform | 2.0 | — |
| redhat ceph_storage | 4.0 | — |
| redhat codeready_linux_builder | 8.0, 9.0, 10.0 | — |
| redhat codeready_linux_builder_eus | 9.4, 9.6, 10.0 | — |
| redhat hardened_images | No range specified | — |
| redhat openshift_ai | 3.4 ≤ v < 3.4.3 | 3.4.3 |
| redhat openshift_container_platform | 4.12 ≤ v < 4.12.92, 4.13 ≤ v < 4.13.68, 4.14 ≤ v < 4.14.68, 4.15 ≤ v < 4.15.65, 4.16 ≤ v < 4.16.64, 4.17 ≤ v < 4.17.55, 4.18 ≤ v < 4.18.44, 4.19 ≤ v < 4.19.33 | 4.12.92, 4.13.68, 4.14.68, 4.15.65, 4.16.64, 4.17.55, 4.18.44, 4.19.33 |
| redhat enterprise_linux | 8.0, 9.0, 10.0 | — |
| redhat enterprise_linux_aus | 8.4, 8.6 | — |
| redhat enterprise_linux_eus | 8.4, 9.4, 9.6, 10.0 | — |
| redhat enterprise_linux_tus | 8.6, 8.8 | — |
| redhat enterprise_linux_update_services_for_sap_solutions | 8.6, 8.8, 9.0, 9.2 | — |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.